<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<title>Best Things to Buy in May 2022 — and 5 Things to Skip</title>
<meta name="Description" content="From mattresses to Star Wars merchandise, find out what the best things to buy are in May, as well as things you should avoid buying.">
<link rel="canonical" href="https://www.savings.com/savvy/best-may-retail-sales">
<meta content="True" name="HandheldFriendly">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=yes">
<meta name="referrer" content="origin-when-cross-origin">
<link rel="preconnect" href="https://node1.sdccdn.com" crossorigin="anonymous">
<link rel="dns-prefetch" href="https://node1.sdccdn.com">
<link rel="preconnect" href="https://www.googletagmanager.com" crossorigin="anonymous">
<link rel="preconnect" href="https://www.google-analytics.com" crossorigin="anonymous">
<link rel="dns-prefetch" href="https://www.googletagmanager.com">
<link rel="dns-prefetch" href="https://www.google-analytics.com">
<link rel="dns-prefetch" href="https://stats.g.doubleclick.net">
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-WMF4HVR');</script>
<!-- End Google Tag Manager -->
<script>
try {
const dataLayer = window.dataLayer || [];
const USER_INTERACTION_EVENTS = [
'scroll', 'click', 'keydown', 'mousemove', 'touchstart',
];
function onUserInteraction(callback) {
const enhancedCallback = () => {
callback();
USER_INTERACTION_EVENTS.forEach((uiEvent) => {
window.removeEventListener(uiEvent, enhancedCallback);
});
}
USER_INTERACTION_EVENTS.forEach((uiEvent) => {
window.addEventListener(uiEvent, enhancedCallback);
});
}
onUserInteraction(function () {
dataLayer.push({
'event': 'userInteractionEvent',
});
// also trigger a custom event for any other local processes that need to happen
var uiEvent = document.createEvent('Event');
uiEvent.initEvent('userInteractionEvent.sdc', true, true);
window.dispatchEvent(uiEvent);
});
} catch (e) {}
</script>
<meta name="google-site-verification" content="867RiPt_hF7jxJZ6Tcm-6KwWSi2lUlPjlMsOWR7Rjp4">
<meta name="google-site-verification" content="9knKIrRzHX6N8W63jt2Ogc6RFL0UGNQBbKudh0RUxes">
<meta property="og:site_name" content="Savings.com">
<meta property="og:title" content="Best Things to Buy in May 2022 &mdash; and 5 Things to Skip">
<meta property="og:type" content="website">
<meta property="og:image" content="https://cdn.sdccdn.com/images/savings/logo/4982729.jpeg?width=500">
<meta property="og:image:alt" content="Best Things to Buy in May 2022 &mdash; and 5 Things to Skip">
<meta property="og:url" content="https://www.savings.com/savvy/best-may-retail-sales">
<meta property="og:description" content="From mattresses to Star Wars merchandise, find out what the best things to buy are in May, as well as things you should avoid buying.">
<meta property="fb:page_id" content="34513493785">
<meta id="fb-app-id" property="fb:app_id" content="130255154655">
<link rel="shortcut icon" href="https://node1.sdccdn.com/images/theme/sdc2/favicon.ico?v=232435f7">
<link rel="apple-touch-icon" sizes="180x180" href="https://node1.sdccdn.com/images/theme/sdc2/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://node1.sdccdn.com/images/theme/sdc2/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://node1.sdccdn.com/images/theme/sdc2/favicon-16x16.png">
<link rel="preload" href="https://node1.sdccdn.com/fonts/poppins/tk-poppins-400.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://node1.sdccdn.com/fonts/poppins/tk-poppins-600.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://node1.sdccdn.com/fonts/webfonts-subset/fa-solid-900.woff2?v=16" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://node1.sdccdn.com/fonts/webfonts-subset/fa-regular-400.woff2?v=16" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://node1.sdccdn.com/fonts/webfonts-subset/fa-light-300.woff2?v=16" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://node1.sdccdn.com/fonts/webfonts-subset/fa-brands-400.woff2?v=16" as="font" type="font/woff2" crossorigin="anonymous">
 <link href="https://node1.sdccdn.com/dist/sdc2/shared.bundle.min.css?v=8c92dea1" rel="stylesheet" rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet';this.removeAttribute('as');">
<link href="https://node1.sdccdn.com/dist/sdc2/common.bundle.min.css?v=9473c8b6" rel="stylesheet" rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet';this.removeAttribute('as');">
<link href="https://node1.sdccdn.com/dist/sdc2/seo-landing.bundle.min.css?v=693046d3" rel="stylesheet" rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet';this.removeAttribute('as');">
<link href="https://node1.sdccdn.com/dist/sdc2/savvy.bundle.min.css?v=5fb8a8a2" rel="stylesheet" rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet';this.removeAttribute('as');">
<script>
!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);
</script>
<!--[if lte IE 9]>
<script src="https://node1.sdccdn.com/js/lib/matchMedia.js?v=a6204a7a"></script>
<script src="https://node1.sdccdn.com/js/lib/matchMedia.addListener.js?v=d11d3551"></script>
<![endif]-->
<script>
var _PageInfo = {
resources: {
js: {},
css: {},
ref: {}
},
auth: {
id: "6Le4LRoUAAAAAI6qiqZizkwQST93_qaC9eYXPMWV",
oauth: {
google: "902053597161-nfnih52u5gko5gg0ei4agl5vhj060343.apps.googleusercontent.com",
googleOneTap: false,
facebook: "159253302502784",
apple: "com.savings.web.signin"},
anonVote: false},
breakpoints: {xs: "0", sm: "375px", md: "768px", lg: "1030px", xl: "1200px"},
loginEnabled: true,
loggedIn: false,
logError: true,
logPopupError: true,
sem: false,
charity: false,
debug: {
entity: {
props: [
{title: "Canonical", value: "https://www.savings.com/savvy/best-may-retail-sales"},
{title: "Meta Desc", value: "From mattresses to Star Wars merchandise, find out what the best things to buy are in May, as well as things you should avoid buying."}
]
}
},
domain: "savings.com",
cdn: {
root: "https://cdn.sdccdn.com",
nodes: ["https://node1.sdccdn.com"],
},
locale: {
zipcode: "",
network: 1 ,
lang: "en_US"
},
theme: "sdc2",
twitter: "savings",
msg: {
ariaNewWindow: "Opens in a new window",
coupon: "coupon",
copy: "Copy",
copied: "Copied",
copyGo: "Copy &amp; Go",
copyCode: "Copy Code",
copyCodeClipboard: "Copy code to clipboard",
copyDeal: "Copy &amp; Get Deal",
getDeal: "Get Deal",
moduleCodeReveal: "Go to store"
},
mvt: {
deviceType: "",
recipeName: "",
recipeId: "",
recipeValue: "",
inPageUrl: ""
},
rewardCashbackFlowEnabled: true,
rewardCashbackFlow: false,
survey: {
pageCount: 0 ,
percentage: 0 ,
urlRegEx: "*" },
entity: {
id: "177",
name: "Best Things to Buy in May 2022 \u2014 and 5 Things to Skip",
type: "article",
url: "/savvy/best-may-retail-sales",
resource: "best-may-retail-sales"
}
};
</script>
</head>
<body class="seo_landing rebrand locale-us">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WMF4HVR" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div id="layout">
<a id="skip-link" href="#wrapper-top" class="btn btn-sm block">Skip to main content</a>
  <header id="header">
<div id="header-disclosure">
<div class="container">
<div class="row">
<div class="col">
<p class="m-b-0 txt-center fog-medium" style="line-height: 1;">
Savings.com may earn a commission when you buy through links on our site. <a href="/info/terms/">Learn More</a>
</p>
</div>
</div>
</div>
</div>
<div id="header-masthead">
<div class="container">
<div class="row">
<div class="col d-flex j-between">
<div id="header-return" class="a-center flex1">
<a href="/" class="link-grey f-14 f-16-lg"><i class="icon fas fa-chevron-left size-12 " aria-hidden="true"></i> Return to Savings.com</a>
</div>
<div id="header-wrapper" class="clearfix">
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "SiteNavigationElement",
"name": ["Coupons", "Stores", "Categories", "Savvy"],
"url": ["https://www.savings.com/coupons", "https://www.savings.com/coupons/stores", "https://www.savings.com/coupons/categories", "https://www.savings.com/savvy"]
}
</script>
<nav id="header-nav">
<ul class="nav-list visible-lg-table center-block header-nav-container">
 <li class="tab">
<a class="coupons" href="/coupons" title="Coupons" >
<span class="tab-txt">Coupons</span>
</a>
</li>
 <li class="tab pos-rel hasDropdown hideDropdown" data-query="/sdc/nav_dropdown.html?tab=merchants">
<a href="/coupons/stores" title="Stores" >
<span class="tab-txt">Stores<i class="icon fas fa-chevron-down v-mid iblock " aria-hidden="true"></i></span>
</a>
<div class="tab-dropdown dropdown-merchants clearfix txt-left">
<div class="tab-dropdown-content flexbox">
<div class="flex1">
<div class="tab-list ">
<span class="tab-list-header secondary-font m-r-1 m-b-1 iblock strong">Shop Popular Stores</span><p class="iblock"><a href="/coupons/stores" class="more">View All Stores</a></p><ul class="pill-list" data-ga-context="top_nav">
<li>
<a class="pill invert" data-ga-context="merchant_macys.com" href="/coupons/macys.com" title="Macys Coupons">Macy's</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_shein.com" href="/coupons/shein.com" title="Shein Coupons">SHEIN</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_homedepot.com" href="/coupons/homedepot.com" title="Home Depot Coupons">Home Depot</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_verizon.com" href="/coupons/verizon.com" title="Verizon Wireless Deals">Verizon</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_officedepot.com" href="/coupons/officedepot.com" title="Office Depot Coupon">Office Depot</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_build.com" href="/coupons/build.com" title="Build.com Coupons">Build.com</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_zales.com" href="/coupons/zales.com" title="Zales Promo Code">Zales</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_att.com" href="/coupons/att.com" title="AT&T Promo Codes">AT&T</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_vistaprint.com" href="/coupons/vistaprint.com" title="Vistaprint Promo Code">Vistaprint</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_cheapoair.com" href="/coupons/cheapoair.com" title="CheapOair Promo Codes">CheapOair</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_4wheelparts.com" href="/coupons/4wheelparts.com" title="4WheelParts Promo Code">4WheelParts</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_greatwolf.com" href="/coupons/greatwolf.com" title="Great Wolf Lodge Coupons">Great Wolf Lodge</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_oldnavy.com" href="/coupons/oldnavy.com" title="Old Navy Coupons">Old Navy</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_lowes.com" href="/coupons/lowes.com" title="Lowes Coupons">Lowe's</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_kohls.com" href="/coupons/kohls.com" title="Kohl's Coupons">Kohl's</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_gap.com" href="/coupons/gap.com" title="Gap Coupons">GAP</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_walmart.com" href="/coupons/walmart.com" title="Walmart Promo Codes">Walmart</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_jcpenney.com" href="/coupons/jcpenney.com" title="JCPenney Coupons">JCPenney</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_bananarepublic.com" href="/coupons/bananarepublic.com" title="Banana Republic Coupons">Banana Republic</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_fanatics.com" href="/coupons/fanatics.com" title="Fanatics Coupons">Fanatics</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_hp.com" href="/coupons/hp.com" title="HP Coupon Codes">HP</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_nordstrom.com" href="/coupons/nordstrom.com" title="Nordstrom Coupons">Nordstrom</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_personalizationmall.com" href="/coupons/personalizationmall.com" title="Personalization Mall Coupons">Personalization Mall</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_target.com" href="/coupons/target.com" title="Target Promo Codes">Target</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_chewy.com" href="/coupons/chewy.com" title="Chewy.com Promo Codes">Chewy.com</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_sportsmansguide.com" href="/coupons/sportsmansguide.com" title="Sportsmans Guide Coupons">Sportsman's Guide</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_hobbylobby.com" href="/coupons/hobbylobby.com" title="Hobby Lobby Coupons">Hobby Lobby</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_childrensplace.com" href="/coupons/childrensplace.com" title="Children's Place Coupons">The Children's Place</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_advanceautoparts.com" href="/coupons/advanceautoparts.com" title="Advance Auto Parts Coupons">Advance Auto Parts</a>
</li>
<li>
<a class="pill invert" data-ga-context="merchant_belk.com" href="/coupons/belk.com" title="Belk Coupon">Belk</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</li>
 <li class="tab pos-rel hasDropdown hideDropdown" data-query="/sdc/nav_dropdown.html?tab=categories">
<a href="/coupons/categories" title="Categories" >
<span class="tab-txt">Categories<i class="icon fas fa-chevron-down v-mid iblock " aria-hidden="true"></i></span>
</a>
<div class="tab-dropdown dropdown-categories clearfix txt-left">
<div class="tab-dropdown-content flexbox">
<div class="flex1">
<div class="tab-list ">
<span class="tab-list-header secondary-font m-r-1 m-b-1 iblock strong">Seasonal Deals</span><ul class="pill-list pill-list--category" data-ga-context="top_nav">
<li>
<a class="pill" data-ga-context="category_mothers-day" href="/coupons/holiday-and-seasonal/mothers-day">Mother's Day</a>
</li>
<li>
<a class="pill" data-ga-context="category_memorial-day" href="/coupons/holiday-and-seasonal/memorial-day">Memorial Day</a>
</li>
</ul>
</div>
<div class="tab-list ">
<span class="tab-list-header secondary-font m-r-1 m-b-1 iblock strong">Shop Top Categories</span><p class="iblock"><a href="/coupons/categories" class="more">View All Categories</a></p><ul class="pill-list pill-list--category" data-ga-context="top_nav">
<li>
<a class="pill" data-ga-context="category_home-and-garden" href="/coupons/home-and-garden">Home & Garden</a>
</li>
<li>
<a class="pill" data-ga-context="category_apparel-and-accessories" href="/coupons/apparel-and-accessories">Apparel & Accessories</a>
</li>
<li>
<a class="pill" data-ga-context="category_food-and-beverage" href="/coupons/food-and-beverage">Food & Beverage</a>
</li>
<li>
<a class="pill" data-ga-context="category_travel" href="/coupons/travel">Travel</a>
</li>
<li>
<a class="pill" data-ga-context="category_health-and-medicine" href="/coupons/health-and-medicine">Health & Medicine</a>
</li>
<li>
<a class="pill" data-ga-context="category_beauty-and-personal-care" href="/coupons/beauty-and-personal-care">Beauty</a>
</li>
<li>
<a class="pill" data-ga-context="category_computers-and-software" href="/coupons/computers-and-software">Computers & Software</a>
</li>
<li>
<a class="pill" data-ga-context="category_wireless-broadband-and-cable" href="/coupons/wireless-broadband-and-cable">Wireless, Broadband & Cable</a>
</li>
<li>
<a class="pill" data-ga-context="category_electronics" href="/coupons/electronics">Electronics</a>
</li>
<li>
<a class="pill" data-ga-context="category_jewelry-and-watches" href="/coupons/apparel-and-accessories/accessories/jewelry-and-watches">Jewelry & Watches</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</li>
 <li class="tab">
<a href="/savvy" title="Savvy" >
<span class="tab-txt">Savvy</span>
</a>
</li>
</ul>
</nav> </div> <script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "SiteNavigationElement",
"name": ["Sign Up", "Login"],
"url": ["https://www.savings.com/account/memberlogin.html", "https://www.savings.com/account/memberlogin.html?familiar=true"]
}
</script>
<div id="header-account">
<ul class="nav-list inline-list visible-lg-block">
<li class="tab action signup" data-action="signup"><a href="/account/memberlogin.html"><span class="tab-txt">Sign Up</span></a></li>
<li class="tab action login last" data-action="login"><a href="/account/memberlogin.html?familiar=true"><span class="tab-txt">Login</span></a></li>
</ul>
</div>
<div class="toggle-group">
<a id="toggle-menu" class="toggle" href="#" title="Menu" aria-expanded="false" aria-label="Toggle navigation"><i class="icon fas fa-bars " aria-hidden="true"></i></a>
</div>
</div>
</div> </div> </div> <div id="content-overlay" class="hideOverlay"></div>
</header> 
<div id="wrapper-top" class="clearfix">


<section id="header-savvy" class="bg-tan">
<div class="container">
<div class="row">
<div class="col d-flex">
<div class="visible-lg-flex a-center flex1">
&nbsp;
</div>
<div class="flex1">
<div id="savvy-logo">
<a href="/savvy" title="Savvy by Savings.com">
<picture class="">
<source srcset="https://node1.sdccdn.com/images/theme/sdc2/logos/savvy_mob.svg?v=fe54e43f" media="(max-width: 1030px)">
<source srcset="https://node1.sdccdn.com/images/theme/sdc2/logos/savvy_desk.svg?v=6bbc8588" media="(min-width: 1031px)">
<img alt="Savvy by Savings.com" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1 1'%3E%3C/svg%3E">
</picture>
</a>
</div>
</div>
<div class="visible-lg-flex j-end a-center flex1">
<ul class="social-links inline-list social-links--round social-links--large">
<li><a href="https://www.facebook.com/Savings" aria-label="Facebook" title="Facebook" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-facebook-f " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://twitter.com/savings" aria-label="Twitter" title="Twitter" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-twitter " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://www.instagram.com/savings_com/" aria-label="Instagram" title="Instagram" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-instagram " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://www.youtube.com/user/SavingsDotCom" aria-label="YouTube" title="YouTube" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-youtube " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://www.linkedin.com/company/savings-com" aria-label="LinkedIn" title="LinkedIn" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-linkedin-in " aria-hidden="true"></i></a></li>
</ul>
</div>
</div>
</div>
</div>
</section>
<section class="bg-tan hidden-lg">
<div class="container">
<div class="row">
<div class="col">
<a href="/" class="link-grey f-14 f-16-lg"><i class="icon fas fa-chevron-left size-12 " aria-hidden="true"></i> Return to Savings.com</a>
</div>
</div>
</div>
</section>
<section class="article-banner">
<div class="container">
<div class="row">
<div class="col">
<picture class="">
<source srcset="https://node1.sdccdn.com/logo/4982729.jpeg?width=317" media="(max-width: 767px)">
<source srcset="https://node1.sdccdn.com/logo/4982729.jpeg?width=578" media="(max-width: 1029px)">
<source srcset="https://node1.sdccdn.com/logo/4982729.jpeg?width=1164" media="(min-width: 1030px)">
<img alt="Best Things to Buy in May 2022 — and 5 Things to Skip" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1365 630'%3E%3C/svg%3E" width="1365" height="630">
</picture>
</div>
</div>
</div>
</section>
<section>
<div class="container">
<div class="row">
<div class="col">
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type":"BreadcrumbList",
"@id":"#BreadcrumbList",
"itemListElement":[
{
"@type":"ListItem",
"@id":"#Page1",
"position":1,
"item":{
"@type":"Thing",
"@id":"#Item1",
"name":"Savings",
"url":"https://www.savings.com"
}
}, {
"@type":"ListItem",
"@id":"#Page2",
"position":2,
"item":{
"@type":"Thing",
"@id":"#Item2",
"name":"Savvy",
"url":"/savvy"
}
}, {
"@type":"ListItem",
"@id":"#Page3",
"position":3,
"item":{
"@type":"Thing",
"@id":"#Item3",
"name":"Best Things to Buy in May",
"url":"/savvy/best-may-retail-sales"
}
}]
}
</script>
<ul class="breadcrumb breadcrumb--large ">
<li>
<a href="https://www.savings.com">Savings</a>
</li>
<li><i class="icon far fa-chevron-right sep " aria-hidden="true"></i></li>
<li>
<a href="/savvy">Savvy</a>
</li>
<li><i class="icon far fa-chevron-right sep " aria-hidden="true"></i></li>
<li>
<span>Best Things to Buy in May</span>
</li>
</ul>
</div>
</div>
</div>
</section>

</div>
<div id="main" class="layout-left" role="main">
<div class="grid-container">


<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "NewsArticle",
"inLanguage": "en-US",
"url": "https://www.savings.com/savvy/best-may-retail-sales",
"mainEntityOfPage": "https://www.savings.com/savvy/best-may-retail-sales",
"image": "https://cdn.sdccdn.com/images/savings/logo/4982729.jpeg?width=500",
"thumbnailUrl": "https://cdn.sdccdn.com/images/savings/logo/4982730.jpeg?width=325",
"name": "Best Things to Buy in May 2022 — and 5 Things to Skip",
"headline": "Best Things to Buy in May 2022 — and 5 Things to Skip",
"description": "From mattresses to Star Wars merchandise, find out what the best things to buy are in May, as well as things you should avoid buying.",
"datePublished": "2022-05-02",
"dateModified": "2022-05-02T10:34:41-0700",
"author": {
"@type": "Person",
"name": "James Moore",
"email": "james.moore@savings.com",
"description": "James Moore is a writer for Savings.com, specializing in tech and gaming content.",
"jobTitle": "Writer, Tech",
"image": {
"@type": "ImageObject",
"url": "https://cdn.sdccdn.com/images/savings/logo/5030246.jpeg"
}
},
"publisher": {
"@type": "Organization",
"name": "Savvy by Savings.com",
"url": "https://www.savings.com/savvy",
"logo": "https://cdn.sdccdn.com/images/theme/sdc2/logos/savvy_desk.svg",
"parentOrganization": {
"@type": "Organization",
"name": "Savings.com",
"url": "https://www.savings.com",
"logo": "https://cdn.sdccdn.com/images/theme/sdc2/logos/savings.svg"
}
}
}
</script>
<div class="container">
<div class="row">
<div class="col">
<div class="layout-container-left">
<section class="layout-container-left__main">
<p class="slug f-14 m-b-2 m-b-1-md">Shopping | Trend</p>
<h1 class="page-title-lg">Best Things to Buy in May 2022 — and 5 Things to Skip</h1>
<div class="author">
<p class="m-b-0">Written by <a class="link-black" href="/author/james-moore">James Moore</a> | May 2, 2022</p>
</div>
<div class="article-markdown markdown">
<div class="mardown-style-wrapper"><style>
.savvy-h3 { margin-bottom: 0px!important; } .skip { margin-top: 25px!important; }
</style>
</div>
<p>May is jam-packed with holidays, so be prepared for door-busting <a href="/savvy/memorial-day-mattress-sales">discounts on mattresses</a> during Memorial Day, <a href="/savvy/zales-mothers-day-sale">great jewelry deals</a> for Mother’s Day, and other incredible <a href="/coupons/holiday-and-seasonal">holiday deals and promotions</a> throughout the month! Thankfully, these celebrations are spread out pretty evenly, which means you don’t have to wait until the end of the month for huge sales. Before you dive into the fray, here are all the items you should buy in May — and a few you should definitely skip.</p>
<div style="height:10px;"></div>
<h2>The Best Things to Buy in May</h2>
<div style="clear:both;margin-top: 15px;"><img style="margin-bottom: 15px;" alt="Furniture" src="" class="lazy" data-original="https://cdn.sdccdn.com/img/best-things-to-buy-in-may1.jpeg">
</div>
<h3>Furniture</h3>
<p>Spring is the season for cleaning out the old and starting something new, which also makes it a great time to find <a href="/coupons/home-and-garden/furniture">discounts on furniture</a>. From couches and armchairs to bed frames and dressers, retailers like <a href="/coupons/homedepot.com">Home Depot</a>, <a href="/coupons/macys.com">Macy’s</a>, and <a href="/coupons/walmart.com">Walmart</a> usually either mark down prices on their furniture or offer coupon codes at checkout. <a href="/coupons/holiday-and-seasonal/memorial-day">Memorial Day</a> is on May 30 this year, so keep that three-day weekend open for all your furniture shopping needs! Some sales begin a week earlier, so keep an eye out for official announcements from your favorite retailers.</p>
<div style="clear:both;margin-top: 50px;"><img style="margin-bottom: 15px;" alt="Appliances" src="" class="lazy" data-original="https://cdn.sdccdn.com/img/best-things-to-buy-in-may2.jpeg">
</div>
<h3>Appliances</h3>
<p>May is right between spring and summer, and as the seasons change, so will your home appliances. Be on the lookout for <a href="/coupons/home-and-garden/kitchen-and-dining">discounts on kitchen appliances</a>, like coffee machines, blenders, toasters, and more. Head over to <a href="/coupons/bestbuy.com">Best Buy</a>, Macy’s, <a href="/coupons/homedepot.com">Home Depot</a>, or <a href="/coupons/lowes.com">Lowe’s</a> and look for exclusive price markdowns.</p>
<div style="clear:both;margin-top: 50px;"><img style="margin-bottom: 15px;" alt="Spring Apparel" src="" class="lazy" data-original="https://cdn.sdccdn.com/img/best-things-to-buy-in-may3.jpeg">
</div>
<h3>Spring Apparel</h3>
<p>A good rule of thumb when shopping for clothes is to buy them out of season for maximum savings. As retailers clear out their inventory to prepare for summer fashion, <a href="/savvy/spring-fashion-trends">markdowns on spring apparel</a> will entice shoppers to clear out available inventory. Check out retailers’ clearance and sales pages on their websites and sign up for their e-newsletters to stay in the know for upcoming promotions and exclusive offers. <a href="/coupons/oldnavy.com">Old Navy</a>, <a href="/coupons/puma.com">PUMA</a>, and <a href="/coupons/kohls.com">Kohl’s</a> are just some of the retailers to keep an eye on.</p>
<div style="clear:both;margin-top: 50px;"><img style="margin-bottom: 15px;" alt="Mattresses" src="" class="lazy" data-original="https://cdn.sdccdn.com/img/best-things-to-buy-in-may4.jpeg">
</div>
<h3>Mattresses</h3>
<p>If you missed out on Presidents Day mattress sales, now’s your chance to swap out your old mattress with a new one this <a href="/coupons/holiday-and-seasonal/memorial-day">Memorial Day</a>! Macy’s, <a href="/coupons/samsclub.com">Sam’s Club</a>, <a href="/coupons/walmart.com">Walmart</a>, and <a href="/coupons/jcpenney.com">JCPenny</a> are known to mark down prices on their mattresses during sales throughout the year, including Memorial Day. Take advantage of the long weekend to decide whether or not to invest in a new mattress. Shoppers might even be able to find discounted mattresses a week in advance, as retailers like to start their promotions early. If you miss out on the Memorial Day mattress sales, your next big opportunity is <a href="/coupons/holiday-and-seasonal/labor-day">Labor Day</a> in September!</p>
<div style="clear:both;margin-top: 50px;"><img style="margin-bottom: 15px;" alt="Star Wars Merchandise" src="" class="lazy" data-original="https://cdn.sdccdn.com/img/best-things-to-buy-in-may5.jpeg">
</div>
<h3>Star Wars Merchandise</h3>
<p>May 4, or “May the Fourth Be With You," is a special day reserved for Star Wars fans of all ages. If you’re a fan of the franchise, then you’ll be happy to know that Star Wars merchandise tends to go on sale for the commemorative day. From apparel to collectibles, celebrate your favorite characters like the legendary Luke Skywalker or the beloved Grogu by shopping at Walmart, Kohl’s, JCPenny, and Best Buy. Expect to see price cuts on anything related to Star Wars — and who knows, some retailers may offer discounts all month long!</p>
<div style="height:60px;"></div>
<h2>5 Things to Skip in May</h2>
<div style="height:5px;"></div>
<h3 class="savvy-h3">1. Swimwear</h3>
<p>Swimwear season doesn’t kick off until June, so it’s best to wait it out a little longer for those swim trunks or bikinis. If you can, you’re probably better off waiting until the end of summer when retailers are clearing out their inventory and preparing for the fall season. Hang on till August for the <a href="/coupons/apparel-and-accessories/swimwear">best deal on swimwear</a>.</p>
<h3 class="savvy-h3 skip">2. Electronics</h3>
<p>The ideal time to buy electronics like <a href="/coupons/computers-and-software/laptop-computers">laptops</a>, desktops, and <a href="/coupons/computers-and-software/tablets">tablets</a> is during <a href="/coupons/holiday-and-seasonal/back-to-school">back-to-school sales</a> in July and August. For even deeper discounts, hold out until November for bigger annual sales like <a href="/circulars/black-friday">Black Friday</a> and <a href="/circulars/cyber-monday">Cyber Monday</a>. Some states offer tax-free shopping days over the summer, but most shoppers would be better suited waiting a few months.</p>
<h3 class="savvy-h3 skip">3. Summer Apparel</h3>
<p>Similar to shopping for spring apparel at the start of the season, avoid shopping for summer apparel during May and the following summer months. Retailers prioritize clearing the racks toward the end of summer to make way for fall apparel, so that’s when you’ll find the best deals. You might snag some deals on summer apparel during Memorial Day weekend, but most retailers offer better discounts in August.</p>
<h3 class="savvy-h3 skip">4. Grills</h3>
<p>Barbecue season starts with Memorial Day and lasts until the last backyard pitmaster hangs up their tongs after <a href="/coupons/holiday-and-seasonal/labor-day">Labor Day weekend</a>. Because of the high demand, retailers won’t usually be marking down the prices for grills and similar outdoor appliances. It’s best to wait until after Labor Day weekend for discounts once grills, and the demand for them, have cooled down.</p>
<h3 class="savvy-h3 skip">5. Outdoor Furniture</h3>
<p>As another summertime favorite, outdoor furniture will be in huge demand as shoppers scramble to prepare for the lazy lounge sessions outdoors. Anything that goes on your patio, from lounge chairs to porch swings, will most likely not go on sale until the fall season. Once the time comes, expect to get <a href="/coupons/home-and-garden/patio-and-outdoor">up to half off on patio furniture</a>.</p>
</div>
</section>
<section class="layout-container-left__sidebar">
<div class="section">
<h3 class="section-header">
You May Also Like
</h3>
<div class="p-tb-3">
<div class="row">
<div class="col-md-6 col-lg-12">
<a class="link-black" href="/savvy/mothers-day-gift-ideas">
<div class="card card--article ">
<picture class="lazy card__image " data-alt="25 Best Mother’s Day Gift Ideas for Every Type of Mom">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5062289.jpeg?width=317" media="(max-width: 767px)">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5062289.jpeg?width=578" media="(min-width: 768px)">
<img alt="25 Best Mother’s Day Gift Ideas for Every Type of Mom" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 580 387'%3E%3C/svg%3E" width="580" height="387">
</picture>
<div class="card__content">
<span class="block card__label">Holiday</span>
<h3 class="card__title">25 Best Mother’s Day Gift Ideas for Every Type of Mom</h3>
<p class="card__date">May 2, 2022</p>
</div>
</div>
</a>
</div>
<div class="col-md-6 col-lg-12">
<a class="link-black" href="/savvy/mothers-day-gift-guide-the-best-self-care-gifts-for-mom">
<div class="card card--article ">
<picture class="lazy card__image " data-alt="2022 Mother’s Day Gift Guide for the Best Self-Care Gifts for Mom">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5062078.jpeg?width=317" media="(max-width: 767px)">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5062078.jpeg?width=578" media="(min-width: 768px)">
<img alt="2022 Mother’s Day Gift Guide for the Best Self-Care Gifts for Mom" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 580 387'%3E%3C/svg%3E" width="580" height="387">
</picture>
<div class="card__content">
<span class="block card__label">Holiday | Wellness</span>
<h3 class="card__title">2022 Mother’s Day Gift Guide for the Best Self-Care Gifts for Mom</h3>
<p class="card__date">May 1, 2022</p>
</div>
</div>
</a>
</div>
<div class="col-md-6 col-lg-12">
<a class="link-black" href="/savvy/best-iherb-deals">
<div class="card card--article ">
<picture class="lazy card__image " data-alt="Best iHerb Deals: Clean Beauty Products Under $20 and Natural Supplements for as Low as $1">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5061956.jpeg?width=317" media="(max-width: 767px)">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5061956.jpeg?width=578" media="(min-width: 768px)">
<img alt="Best iHerb Deals: Clean Beauty Products Under $20 and Natural Supplements for as Low as $1" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 580 387'%3E%3C/svg%3E" width="580" height="387">
</picture>
<div class="card__content">
<span class="block card__label">Sustainability | Wellness</span>
<h3 class="card__title">Best iHerb Deals: Clean Beauty Products Under $20 and Natural Supplements for as Low as $1</h3>
<p class="card__date">April 30, 2022</p>
</div>
</div>
</a>
</div>
<div class="col-md-6 col-lg-12">
<a class="link-black" href="/savvy/michael-kors-mothers-day-sale">
<div class="card card--article ">
<picture class="lazy card__image " data-alt="Michael Kors Mother’s Day Sale: 12 Gift Ideas for Every Mom">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5061923.jpeg?width=317" media="(max-width: 767px)">
<source srcset="" data-original="https://node1.sdccdn.com/logo/5061923.jpeg?width=578" media="(min-width: 768px)">
<img alt="Michael Kors Mother’s Day Sale: 12 Gift Ideas for Every Mom" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 580 387'%3E%3C/svg%3E" width="580" height="387">
</picture>
<div class="card__content">
<span class="block card__label">Fashion | Holiday</span>
<h3 class="card__title">Michael Kors Mother’s Day Sale: 12 Gift Ideas for Every Mom</h3>
<p class="card__date">April 28, 2022</p>
</div>
</div>
</a>
</div>
</div>
</div>
</div>

<div id="tout-email-signup" class="section module">
<div class="wrapper-success">
<h3 class="headline">Sign up for daily deals.</h3>
<p class="sub-headline m-b-0">Get personalized inspiration and exclusive deals from your favorite brands straight to your inbox.</p>
<div class="email-signup lazy " data-ga-context="signup_tout">
<form class="form-register center-block clearfix " data-ajax="true">
<input type="hidden" name="reurl" value="/article-landing-page.html"/>
<input type="hidden" name="dailyNewsletter" value="true"/>
 <input type="hidden" name="sut" value="1bxv1:1651559129931:1488773002Rftwqm/c4YxzljLjRN8f1GlCvkY="/>
<div class="wrapper-captcha" data-message="" data-init="false" data-ajax="false">
<div class="g-recaptcha hide " data-size="invisible"></div>
</div>
<div class="form-group email clearfix">
 <input  class="rnd email input-field w-100 shadow--large" name="email" type="email" maxlength="255" placeholder="Enter Your Email" aria-label="Enter Your Email"/>
</div>
<div class="submit">
  <button class="btn blue " type="submit"><span class="btn-text">Subscribe</span></button>
</div>
</form>
</div>
<p class="f-10 m-b-0">
We take your privacy seriously.<br/>Read our <a href="/info/privacy/?utm_source=homepage&amp;utm_medium=email&amp;utm_campaign=signup&amp;utm_term=privacy" target="_blank">Privacy Policy</a>
</p>
</div>
<img alt="Sign up for our newsletter" class=" lazy" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/newsletter-signup.svg?v=db79a655"/></div>
</section>
</div>
</div>
</div>
</div>

</div>
</div>
</div> <footer id="footer" style="overflow: hidden;">
<section class="txt-left bg-tan clearfix">
<div class="container">
<div class="row">
<div class="col">
<div class="footer-links">
<div class="row clearfix ">
<div class="col-6 col-lg-3">
<ul class="entity-list" data-ga-context="footer_nav">
<li class="slug ">
Top Categories
</li>
 <li><a href="/coupons/food-and-beverage" title="Food & Beverage Coupons" class="entity-link" data-ga-context="category_food-and-beverage">Food & Beverage Coupons</a></li>
<li><a href="/coupons/home-and-garden" title="Home & Garden Coupons" class="entity-link" data-ga-context="category_home-and-garden">Home & Garden Coupons</a></li>
<li><a href="/coupons/apparel-and-accessories" title="Clothing Coupons" class="entity-link" data-ga-context="category_apparel-and-accessories">Clothing Coupons</a></li>
<li><a href="/coupons/health-and-medicine" title="Health & Medicine Coupons" class="entity-link" data-ga-context="category_health-and-medicine">Health & Medicine Coupons</a></li>
<li><a href="/coupons/beauty-and-personal-care" title="Beauty Coupons" class="entity-link" data-ga-context="category_beauty-and-personal-care">Beauty Coupons</a></li>
<li><a href="/coupons/baby-and-nursery/baby-gear" title="Baby & Kids Gear Coupons" class="entity-link" data-ga-context="category_baby-gear">Baby & Kids Gear Coupons</a></li>
<li><a href="/coupons/electronics" title="Electronics Coupons" class="entity-link" data-ga-context="category_electronics">Electronics Coupons</a></li>
<li><a href="/coupons/apparel-and-accessories/accessories/jewelry-and-watches" title="Jewelry & Watch Coupons" class="entity-link" data-ga-context="category_jewelry-and-watches">Jewelry & Watch Coupons</a></li>
<li class="m-t-1 ">
<a href="/coupons/categories" title="All Categories">All Categories</a>
</li>
</ul>
</div>
<div class="col-6 col-lg-3">
<ul class="entity-list" data-ga-context="footer_nav">
<li class="slug ">
Seasonal Deals
</li>
 <li><a href="/coupons/holiday-and-seasonal/summer" title="Summer Deals" class="entity-link" data-ga-context="category_summer">Summer Deals</a></li>
<li><a href="/coupons/holiday-and-seasonal/graduation" title="Graduation Deals" class="entity-link" data-ga-context="category_graduation">Graduation Deals</a></li>
<li><a href="/coupons/holiday-and-seasonal/memorial-day" title="Memorial Day Deals" class="entity-link" data-ga-context="category_memorial-day">Memorial Day Deals</a></li>
<li><a href="/coupons/holiday-and-seasonal/mothers-day" title="Mother's Day Deals" class="entity-link" data-ga-context="category_mothers-day">Mother's Day Deals</a></li>
</ul>
</div>
<div class="col-6 col-lg-3">
<ul>
<li class="slug ">
<a href="/info/" title="About Savings.com">About Savings.com</a>
</li>
<li>
<a href="/savvy" title="Savvy">Savvy</a>
</li>
<li>
<a href="/insights" title="Shopping Insights">Shopping Insights</a>
</li>
<li>
<a href="/info/faq/" title="FAQ">FAQ</a>
</li>
<li>
<a href="/info/contact_us/" title="Contact Us">Contact Us</a>
</li>
<li>
<a href="https://savings.zendesk.com" target="_blank" rel="nofollow noopener" aria-label="Opens in a new window" title="Help Desk">Help Desk</a>
</li>
<li>
<a href="#" class="manage-prefs-action" title="Manage Preferences">Manage Preferences</a>
</li>
<li>
<a href="/info/accessibility/" title="Accessibility">Accessibility</a>
</li>
<li>
<a href="/info/job_opportunities/" title="Careers">Careers</a>
</li>
</ul>
</div>
<div class="col-6 col-lg-3">
<ul>
<li class="slug ">
Legal
</li>
<li>
<a href="/info/terms/" class="terms" rel="nofollow noopener" aria-label="Opens in a new window" title="Terms of Service">Terms of Service</a>
</li>
<li>
<a href="/info/privacy/" class="privacy" rel="nofollow noopener" aria-label="Opens in a new window" title="Privacy Policy">Privacy Policy</a>
</li>
<li>
<a href="/info/extension_eula/" rel="nofollow noopener" aria-label="Opens in a new window" title="Browser EULA">Browser EULA</a>
</li>
<li>
<a href="#" class="opt-out-action" rel="nofollow noopener" aria-label="Opens in a new window" title="Do Not Sell My Info">Do Not Sell My Info</a>
</li>
</ul>
</div>
</div>
</div>
<div class="row">
<div class="col">
<ul class="intl-sites">
<li class="intl-sites__title">Find Us Internationally!</li>
<li class="intl-sites__list">
<ul>
<li>
<a class="intl-sites__flag" href="https://www.savoo.co.uk" title="Savoo">
<img alt="Savoo" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/GB-Flag.svg?width=30&amp;height=30&amp;v=ce0766e6"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.de" title="Savoo.de">
<img alt="Savoo.de" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/DE-Flag.svg?width=30&amp;height=30&amp;v=244d47d2"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.fr" title="Savoo.fr">
<img alt="Savoo.fr" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/FR-Flag.svg?width=30&amp;height=30&amp;v=64fb8882"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.it" title="Savoo.it">
<img alt="Savoo.it" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/IT-Flag.svg?width=30&amp;height=30&amp;v=40605682"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.es" title="Savoo.es">
<img alt="Savoo.es" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/ES-Flag.svg?width=30&amp;height=30&amp;v=eb970232"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.nl" title="Savoo.nl">
<img alt="Savoo.nl" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/NL-Flag.svg?width=30&amp;height=30&amp;v=7b33375"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.com.au" title="Savoo.com.au">
<img alt="Savoo.com.au" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/AU-Flag.svg?width=30&amp;height=30&amp;v=d0706b0"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.com.br" title="Savoo.com.br">
<img alt="Savoo.com.br" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/BR-Flag.svg?width=30&amp;height=30&amp;v=459e05d4"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.ca" title="Savoo.ca">
<img alt="Savoo.ca" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/CA-Flag.svg?width=30&amp;height=30&amp;v=ad3368bb"/></a>
</li>
<li>
<a class="intl-sites__flag" href="https://www.savoo.com.mx" title="Savoo.com.mx">
<img alt="Savoo.com.mx" class=" lazy" width="30" height="30" src="https://node1.sdccdn.com/images/savings/1x1.gif?width=1&amp;height=1&amp;v=cb8abdab" data-original="https://node1.sdccdn.com/images/theme/sdc2/flags/MX-Flag.svg?width=30&amp;height=30&amp;v=32fe8e02"/></a>
</li>
</ul>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="p-tb-3 bg-peach">
<div class="container txt-center">
<div class="row">
<div class="col">
<div class="email-signup hasBg lazy large " data-ga-context="footer">
<form class="form-register center-block clearfix " data-ajax="true">
<input type="hidden" name="reurl" value="/article-landing-page.html"/>
<input type="hidden" name="dailyNewsletter" value="true"/>
 <input type="hidden" name="sut" value="1bxv1:1651559129941:1488773002AoPjg/dwcclcUA2NlFQaVhwBYu4="/>
<div class="wrapper-captcha" data-message="" data-init="false" data-ajax="false">
<div class="g-recaptcha hide " data-size="invisible"></div>
</div>
<p class="form-headline">Subscribe to get hand-picked deals direct to your inbox</p>
<div class="form-group email clearfix">
<div class="wrapper">
 <input  class="rnd email input-field" name="email" type="email" maxlength="255" placeholder="Enter Your Email" aria-label="Enter Your Email"/>
<button type="submit" class="btn blue">Subscribe</button>
</div>
</div>
 <p class="legal">
We take your privacy seriously.
Read our
<a href="/info/privacy/" target="_blank">Privacy Policy</a>.
</p>
</form>
</div>
</div>
</div>
</div>
</section>
<section class="bg-white p-tb-3">
<div class="container">
<div class="row">
<div class="col d-lg-flex a-center">
<div class="center-block" style="max-width: 150px;">
<img alt="Savings.com" width="300" height="49" src="https://node1.sdccdn.com/images/theme/sdc2/logos/savings.svg?width=220&amp;v=d434b2d1"/>
</div>
<div style="flex: 1;">
<p class="m-tb-2 m-0-lg txt-center f-13 f-14-md">&copy; 2022 Savings.com. All Rights Reserved.</p>
</div>
<div>
<ul class="social-links inline-list social-links--round social-links--large">
<li><a href="https://www.facebook.com/Savings" aria-label="Facebook" title="Facebook" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-facebook-f " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://twitter.com/savings" aria-label="Twitter" title="Twitter" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-twitter " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://www.instagram.com/savings_com/" aria-label="Instagram" title="Instagram" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-instagram " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://www.youtube.com/user/SavingsDotCom" aria-label="YouTube" title="YouTube" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-youtube " aria-hidden="true"></i></a></li>
<li class="ml-3"><a href="https://www.linkedin.com/company/savings-com" aria-label="LinkedIn" title="LinkedIn" target="_blank" rel="noopener" aria-label="Opens in a new window"><i class="icon fab fa-linkedin-in " aria-hidden="true"></i></a></li>
</ul>
</div>
</div>
</div>
</div>
</section>
</footer>
<a href="/honeypot.html" aria-label="honeypot"><!--spambots--></a>
<div id="back-to-top"><i class="icon fas fa-arrow-up size-26 " aria-hidden="true"></i></div>
  <script src="https://node1.sdccdn.com/dist/sdc2/shared.bundle.min.js?v=f91d84f2" async crossorigin="anonymous"></script>
 <script src="https://node1.sdccdn.com/dist/sdc2/common.bundle.min.js?v=b03e1c77" async crossorigin="anonymous"></script>
 <script src="https://node1.sdccdn.com/dist/sdc2/seo-landing.bundle.min.js?v=2e98b8c8" async crossorigin="anonymous"></script>
</body>
</html>
